As you already know the MissionX data file is based on English vocabulary and since my native tongue is not English, some of the words I use might not be accurate enough by themselves and it might cause some confusion ( for designers anyway ), This is why I wrote the designer guide, and later the Practical Tutorials, which I believe are better then the "Designer Guide" hands on section.
Here are some confusing Elements or attributes I used that might have a better English representative:
- <Objective>: I know that in a first glance this looks puzzling. An objective is "something" you need to reach a target or set of targets. This is why you can design an Objective like: Fly to LOWI from Cyprus airport. But this describes the main objective, not the sub Objectives in it. Lets say that your first stop should be in Greece and only then you should continue to LOWI airport.
In that case, what is the Objective ?
When I first designed the Elements and their meanings, I did not look at Objective as a "Main target you should achieve", but more of a step in the way to reach the Global Objective.
- tolerateDistance & tolerateElev: I hoped that these targets attributes names will explain themselves but I'm not sure they represent the best words for these attributes.
tolerateDistance: the planes distance from target which the plugin will flag as accomplished.
tolerateElev: the planes elevation relative to target in order to flag the target as accomplished.
You can mixed them both so the target will be flagged as success if both of them accomplished.
- zuluTolerance: An attribute that defines the added time a plane should travel in order to reach a target.
My thoughts: Useless attribute, you should use the timeToCount and define it with the tolerance time. If you need 5 minutes to reach a target and you want to add another 30 seconds, then just define the timeToCount as 5.5.
- All <Objective> element will be renamed to <Checkpoint>: This will better represent what I really meant when designing the plugin file in the first place. This is also better reflects the
[save checkpoint] button in the Briefer widget.
- I want to do a better redesign of the <Objective> element ( I still use the old meaning and not the newer one ). I want to add the <Settings> element that will hold all the <Objective> special attributes, meaning:
Weather, Weight, PathHelper and <ApplyLogic> elements will be defined under the <Settings> while giving up on some of the other Elements.
<Forces> element will be deprecated.
<Weight> element will move under the <Settings> element and so on.
If you have designed a mission with the plugin, you can send me an e-mail regarding:
> Better element or attributes naming.
> Better construction of the Mission data file.
> Correct language mistakes.
If you did not design a mission but have a good English vocabulary you can:
> Correct language mistakes.
> Propose better or more accurate English grammar in the Designer Guide or other documents relevant to Mission-X.
Please do not send me Feature request as part of a suggested naming proposal. Send it to me as a different e-mail.
Until next update have a great siming